flat assembler
Message board for the users of flat assembler.
 Home   FAQ   Search   Register 
 Profile   Log in to check your private messages   Log in 
flat assembler > IDE Development > AutoIt With FASM problem

Author
Thread Post new topic Reply to topic
NEASM



Joined: 13 Apr 2018
Posts: 7

AutoIt With FASM problem

Hello. I have a problem with AutoIt. The function "AU3_ClipPut" serves for putting a string in the clipboard. But, the function does not work properly, in the clipboard appear Chinese characters of which I do not understand the origin. Can you help me?

It should insert this string in the clipboard:

Code:
Ogni finestra e stata minimizzata.



But, insert this:

Code:
杏楮映湩獥牴⁡⁥瑳瑡⁡業楮業空瑡⹡



[/code]


Description:
Download
Filename: autoitfasm.zip
Filesize: 199.57 KB
Downloaded: 20 Time(s)

Post 20 May 2018, 11:38
View user's profile Send private message Reply with quote
Picnic



Joined: 05 May 2007
Posts: 1230
Location: Icarian Sea

Hi,

Try declaring string as unicode and see if it works.


Code:

include 'INCLUDE\win32w.inc'

hello du "Ogni finestra e stata minimizzata."0


Post 05 Jun 2018, 11:16
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >

Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Main index   Download   Documentation   Examples   Message board
Copyright © 2004-2018, Tomasz Grysztar.
Powered by rwasa.