flat assembler
Message board for the users of flat assembler.
 Home   FAQ   Search   Register 
 Profile   Log in to check your private messages   Log in 
flat assembler > Projects and Ideas > Trying to get MiniDos running

Author
Thread Post new topic Reply to topic
Robocod



Joined: 05 Mar 2018
Posts: 8

Trying to get MiniDos running

I'm currently trying to have minidos run and am running into difficulties. This one is the project that Dex has made. Has anyone gotten it to work?
Post 13 Mar 2018, 17:11
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15643
Location: Thasus

Link?
Post 13 Mar 2018, 22:51
View user's profile Send private message Visit poster's website Reply with quote
Robocod



Joined: 05 Mar 2018
Posts: 8

Post 13 Mar 2018, 23:01
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15643
Location: Thasus

What difficulties do you have?
Post 13 Mar 2018, 23:21
View user's profile Send private message Visit poster's website Reply with quote
Robocod



Joined: 05 Mar 2018
Posts: 8

I do t know how to get it too run
Post 13 Mar 2018, 23:30
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15643
Location: Thasus

Please be more specific.

You can't assemble it? You can't install it? You can't boot it? It crashes? It freezes? It dies? It reboots? Blank screen?
Post 13 Mar 2018, 23:39
View user's profile Send private message Visit poster's website Reply with quote
Robocod



Joined: 05 Mar 2018
Posts: 8

I can't assemble it. Sorry, I was replying on my phone. I'm using my laptop now. I'm using it as a learning tool, as I'm new to the whole OS programming subject. So, my problem is I can't assemble the files and get MiniDOS to run.
Post 13 Mar 2018, 23:42
View user's profile Send private message Reply with quote
Robocod



Joined: 05 Mar 2018
Posts: 8

Like turning it into an ISO file and having it run.
Post 13 Mar 2018, 23:55
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15643
Location: Thasus

Where does it fail? Which line? Please show us the error code and the failing line.
Post 14 Mar 2018, 10:39
View user's profile Send private message Visit poster's website Reply with quote
ManOfSteel



Joined: 02 Feb 2005
Posts: 1141

It assembles fine here. The only problem I encountered was with the include 'Data.inc' line. But it's a non-issue on MS-DOS or Windows.
Post 14 Mar 2018, 20:24
View user's profile Send private message Reply with quote
Robocod



Joined: 05 Mar 2018
Posts: 8

I'm having trouble and can't figure it out. I'm just looking how I can make it run
Post 24 Mar 2018, 13:01
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15643
Location: Thasus


Robocod wrote:
I'm having trouble and can't figure it out. I'm just looking how I can make it run

Please be more specific.

You can't assemble it? You can't install it? You can't boot it? It crashes? It freezes? It dies? It reboots? Blank screen?
Post 24 Mar 2018, 13:11
View user's profile Send private message Visit poster's website Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >

Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Main index   Download   Documentation   Examples   Message board
Copyright © 2004-2018, Tomasz Grysztar.
Powered by rwasa.