flat assembler
Message board for the users of flat assembler.

Index > Compiler Internals > FASM Ver 1.67.30.2 Crashing

Author
Thread Post new topic Reply to topic
Kel



Joined: 11 Feb 2009
Posts: 8
Location: Australia
Kel
Hi, just wondering if anyone else has had any problems with the FASM 1.67.30.2 version as I seem to be getting a intermittent problem with saving files with a different file name and or path.

Just for clarity this has happened on two computers that i have an ADM Sempron +2800 and a Intel Celeron D both have XP SP3 and AGV 8.0 Free
Post 11 Feb 2009, 03:38
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17271
Location: In your JS exploiting you and your system
revolution
What sort of crash? Do you get an error message from fasm or from Windows? Does it need a specific source file to make it crash? Does it crash when you compile the examples?
Post 11 Feb 2009, 04:23
View user's profile Send private message Visit poster's website Reply with quote
Kel



Joined: 11 Feb 2009
Posts: 8
Location: Australia
Kel
Windows displays that annoying this app must close send crash dump to MS dialogue box then closes FASM and i lose all the work that i just wrote without compiling as the work is not finished it seems to have done it with a few different source files as well although it dose compile quite well without saving...

not sure if its really is a problem with FASM exactly though.
I have been looking for the crash dump and have not been able to find it yet...
Post 11 Feb 2009, 05:28
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17271
Location: In your JS exploiting you and your system
revolution
Does it happen with the console version or the GUI version? I've never had a problem with the console version. Can you post some code here that reproduces the problem?
Post 11 Feb 2009, 05:40
View user's profile Send private message Visit poster's website Reply with quote
Kel



Joined: 11 Feb 2009
Posts: 8
Location: Australia
Kel
I'm using the GUI version and i did some more testing and it really appears that if you take a file and rename it plus move it to a new path
at the same time then this error occurs anyway here is the template file that I've been using


Description:
Download
Filename: BlankTemp.ASM
Filesize: 489 Bytes
Downloaded: 177 Time(s)

Post 11 Feb 2009, 08:53
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.