flat assembler
Message board for the users of flat assembler.

Index > Main > Memory Operating System (FAMOS)

Goto page Previous  1, 2, 3, 4
Author
Thread Post new topic Reply to topic
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
neville wrote:
Sounds good. I might give it a go sometime.

Did you play your own WAV data using LOAD32 before USBAUDIO? And what USB audio device do you have Dex?


Yes and i will check device post back , as i am not on that pc.
Post 28 Jul 2008, 13:51
View user's profile Send private message Reply with quote
neville



Joined: 13 Jul 2008
Posts: 507
Location: New Zealand
neville
Dex4u wrote:
Yes and i will check device post back , as i am not on that pc.

Did you ever check those USB speakers Dex?

Enumerating USB audio devices can be a bit of a mission so I'm interested to know which ones give good results and which ones don't!

_________________
FAMOS - the first memory operating system
Post 31 Jul 2008, 04:30
View user's profile Send private message Visit poster's website Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Sure these are the once i used
Altec Lansing XT1 USB Powered Speakers
And they work great, thats why i want a DexOS ver.
PS: What type do you have ?.
Post 31 Jul 2008, 15:18
View user's profile Send private message Reply with quote
neville



Joined: 13 Jul 2008
Posts: 507
Location: New Zealand
neville
Dex4u wrote:
Sure these are the once i used
Altec Lansing XT1 USB Powered Speakers
And they work great, thats why i want a DexOS ver.
PS: What type do you have ?.


Thanks for the info. I have "Zone Notebook" USB speakers, and also a USB Headset adapter with 2 x 3.5mm phono sockets for microphone and headphone or amplified speakers.

During my enumeration tests I found the headset adapter "lied" about its maximum packet length for the isochronous endpoint; as a result I no longer ask the device for this parameter but I just set it to a standard default value based on other information it supplies. If wrong, the audio would sound distorted or even completely garbled so I guess your speakers are OK! I hope more people will tell me what happened for them. I see 26 people have downloaded USBAUDIO now...

_________________
FAMOS - the first memory operating system
Post 03 Aug 2008, 02:04
View user's profile Send private message Visit poster's website Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Does the mic part work on your setup. I have the same problem with feed back with my OS, lots of downloads, but little feed back.
Have you tryed posting it on the test place on this forum http://forum.osdev.org/
And thanks letting me know your setup.

I have a problem with some of my USB code for my OS, it works fine with
UHCI (Universal Host Controller Interface) but if EHCI (Extended Host Controller Interface) is present, it does not detect USB plugged in or out.
Let me know if you want to see code.
Post 03 Aug 2008, 15:19
View user's profile Send private message Reply with quote
neville



Joined: 13 Jul 2008
Posts: 507
Location: New Zealand
neville
Dex4u wrote:
Does the mic part work on your setup.

Yes, I've added an experimental Record function to my audio player in FAMOS ver 1.10, and I have managed to successfully record and playback, but the process is still far from user-friendly.

Quote:
I have a problem with some of my USB code for my OS, it works fine with UHCI (Universal Host Controller Interface) but if EHCI (Extended Host Controller Interface) is present, it does not detect USB plugged in or out. Let me know if you want to see code.


I've only implemented UHCI so far, but some machines with EHCI successfully do fall back to UHCI (for USB1.1 devices), others don't.

Do you have a working UHCI stack in DexOS? Or are you just detecting UHCI port status using PCI functions? If you can process transactions already that would make a port of USBAUDIO much easier I guess, especially with the code... Then all you really need is a USB audio driver.

_________________
FAMOS - the first memory operating system
Post 04 Aug 2008, 05:29
View user's profile Send private message Visit poster's website Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
neville wrote:


I've only implemented UHCI so far, but some machines with EHCI successfully do fall back to UHCI (for USB1.1 devices), others don't.

Thats really cool Cool .
Quote:

Do you have a working UHCI stack in DexOS? Or are you just detecting UHCI port status using PCI functions? If you can process transactions already that would make a port of USBAUDIO much easier I guess, especially with the code... Then all you really need is a USB audio driver.

I have only got as far as UHCI port status using PCI functions, it a on going project by members of team DexOS, i will PM you a link to the code, so you can give me some pointes.
Post 04 Aug 2008, 17:44
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  
Goto page Previous  1, 2, 3, 4

< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on YouTube, Twitter.

Website powered by rwasa.