flat assembler
Message board for the users of flat assembler.

Index > Main > possible bug, "end s"

Author
Thread Post new topic Reply to topic
sleepsleep



Joined: 05 Oct 2006
Posts: 8885
Location: ˛                             ⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣⁣Posts: 334455
sleepsleep
hi,
i somehow discover that if u replace the ends (end structure) with "end s"
ur PC will use up all the paging memory

* don't try on a production system Exclamation
Post 06 Feb 2008, 16:43
View user's profile Send private message Reply with quote
LocoDelAssembly
Your code has a bug


Joined: 06 May 2005
Posts: 4633
Location: Argentina
LocoDelAssembly
If it is alone then you will have enough memory to recieve "invalid argument", otherwise the problem is that all the lines below are still interpreted as part of the struct and that takes up all memory (not sure the reason).

Feel free to try on production system, it will only take up to the memory you set for fasm, not more.

[edit] Seems to be ".end entrypoint" the causant of full memory depletion when you use "end s"[/edit]
Post 06 Feb 2008, 16:50
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.