flat assembler
Message board for the users of flat assembler.

Index > MenuetOS > MenuetOS 32bit Networking

Author
Thread Post new topic Reply to topic
kcghost



Joined: 14 Jul 2007
Posts: 2
kcghost
I am using the latest version of the 32-bit version of MenuetOS off a floppy (I would use 64, but it doesnt work on my computer).

I have a strange problem with networking: I bring up Stack config and the DHCP client hoping it can detect my router. I use Packet Driver, IP server Assigned, and the DHCP client suddenly works great and detects everything. However, none of the other applications work at all. Its as if im not connected, chess, telnet, httpc all dont even seem to try to make a connection. I dont know whats going wrong, the DHCP seems fine, I can even see it show up on my router.

However I do see on my router that the MAC address is all zeros, maybe this is causing a problem. Anyone have any ideas of how to fix this?
Post 14 Jul 2007, 06:10
View user's profile Send private message Reply with quote
Ville



Joined: 17 Jun 2003
Posts: 230
Ville
After reading IP addresses with DHCP, you need to manually enter the values to STACKCFG.
Post 14 Jul 2007, 19:17
View user's profile Send private message Reply with quote
kcghost



Joined: 14 Jul 2007
Posts: 2
kcghost
ah, thanks. Everything works beautifully now.
Post 14 Jul 2007, 23:37
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.