flat assembler
Message board for the users of flat assembler.

Index > Windows > Beach Boys Through PC Speaker

Author
Thread Post new topic Reply to topic
DJ Mauretto



Joined: 14 Mar 2007
Posts: 464
Location: Rome,Italy
DJ Mauretto
Hi all Windows Coder Smile
I have made a little program that play Beach Boys sound through Pc Speaker..
Please note that this program need subsequent requirement:
OS , Windows 2000, Xp , 2003 Server
CPU with RDTSC
PC Desktop ( NO LAPTOP ) with PC Speaker
Administrator Rights.

During the music play , computer is freeze because i need prevent Interrupt
all in User Mode without Driver Wink

ENJOY
Post 30 Mar 2007, 15:57
View user's profile Send private message Reply with quote
LocoDelAssembly
Your code has a bug


Joined: 06 May 2005
Posts: 4633
Location: Argentina
LocoDelAssembly
I get "Failed to set direct access the I/O ports" error on WinXP SP2
Post 30 Mar 2007, 16:41
View user's profile Send private message Reply with quote
vid
Verbosity in development


Joined: 05 Sep 2003
Posts: 7105
Location: Slovakia
vid
baaaa baaaa baaaa barbara ann Cool

too bad i only have notebook, so i didn't try. anyway, there were few very good MIDI players for PC Speaker in DOS
Post 30 Mar 2007, 17:28
View user's profile Send private message Visit poster's website AIM Address MSN Messenger ICQ Number Reply with quote
DJ Mauretto



Joined: 14 Mar 2007
Posts: 464
Location: Rome,Italy
DJ Mauretto
Hi Vid Very Happy
Note that this program don't play beep or midi note ,but audio wave file in raw format,without header Wink
I tryed on 2 PC with XP pro SP2 it's good..
About user rights management setting search with google , M$ OS are boring with account etc...
Post 30 Mar 2007, 18:13
View user's profile Send private message Reply with quote
kandamun



Joined: 20 Jul 2005
Posts: 25
kandamun
Very Happy
Nice!

It is funny - I have been playing with windows privileges at work for two day.
You try to enable SeTcbPrivilege, but it has to be granted to current user first.
So, for those how want to avoid "Failed to set direct access the I/O ports" error :

use the "Local Computer Policy" ( or gpedit.msc )
in the MMC and grant the "Act as part of the operating system"
to your user via:
Code:
      Local Computer Policy
          Computer Configuration
              Windows Settings
                  Security Settings
                      Local Policies
                          User Rights Management
    


Alos you MUST logoff / logon for the policy to take effect.

And also I get "Privileged Instruction" exception on CLI, but afer 'continue' in the debugger I hear the tune.
Post 03 Apr 2007, 18:14
View user's profile Send private message ICQ Number Reply with quote
DJ Mauretto



Joined: 14 Mar 2007
Posts: 464
Location: Rome,Italy
DJ Mauretto
Nice Work kandamun Wink
Post 03 Apr 2007, 19:18
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.