flat assembler
Message board for the users of flat assembler.

Index > OS Construction > DexOS web server

Author
Thread Post new topic Reply to topic
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
I am testing DexOS web server running on DexOS, full code with fasm.
Click on the link, if you see the basic page, it works and still on line
SERVER OFF LINE


Last edited by Dex4u on 25 Feb 2007, 04:01; edited 1 time in total
Post 24 Feb 2007, 23:31
View user's profile Send private message Reply with quote
DOS386



Joined: 08 Dec 2006
Posts: 1901
DOS386
Quote:
Welcome to DexOS test page.
This is running on DexOS Server, which is running on the DexOS OS
A world first, coded by team DexOS
Cool Wink


1. Attempt timeouted cca 30 min ago Mad

Now it works Smile

_________________
Bug Nr.: 12345

Title: Hello World program compiles to 100 KB !!!

Status: Closed: NOT a Bug
Post 25 Feb 2007, 00:18
View user's profile Send private message Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Thank for test NTOSKRNL_VXE, There is a bug that will mean it stick in a synrecieved state, but i will fix that tomorrow
Post 25 Feb 2007, 01:21
View user's profile Send private message Reply with quote
grunge



Joined: 11 Sep 2005
Posts: 21
Location: Brasil
grunge
Very good work! the server show only pure html???

good work,

grunge
Post 25 Feb 2007, 01:23
View user's profile Send private message Reply with quote
hckr83



Joined: 12 Nov 2006
Posts: 86
Location: usa
hckr83
wierd..did I crash your server?
I tried doing a bit of fun by sending random stuff to port 80 by telnet...and tried doing ping(which works nicely) and tried doing ftp://...immediantly after that, I couldn't get it to load...
wierd..btw don't consider me a person that knows how to crash anything, I only was seeing what it would do...
Post 25 Feb 2007, 01:25
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Thanks both for testing.
@grunge, I have implemented a full tcp/ip stack and the server will be able to server images etc.
But for testing i will keep it simple.
@hck83, there is a bug in the server code that waits for a ACK and does not test for RST which it should.
If you do something like close browser half way through or the above it would send me a RST, it would leve server in a wait state, But this will be fix by tomorrow.
Check this flow chart


Description:
Filesize: 19.72 KB
Viewed: 1508 Time(s)

state-diagram-small.gif


Post 25 Feb 2007, 02:03
View user's profile Send private message Reply with quote
HyperVista



Joined: 18 Apr 2005
Posts: 691
Location: Virginia, USA
HyperVista
Quote:
Welcome to DexOS test page.
This is running on DexOS Server, which is running on the DexOS OS
A world first, coded by team DexOS
Cool Wink


Very cool, indeed! Well done Dex!
Post 25 Feb 2007, 04:02
View user's profile Send private message Visit poster's website Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
You only just made it HperVista, as i turn it off 3 mins later ;)

[EDIT] SERVER OFFLINE [/EDIT]


Last edited by Dex4u on 27 Feb 2007, 15:23; edited 1 time in total
Post 25 Feb 2007, 19:24
View user's profile Send private message Reply with quote
Mac2004



Joined: 15 Dec 2003
Posts: 313
Mac2004
Hi Dex!

Quote:
DexOS test server back on line
http://86.15.253.182


I tried the link, but it gave no response at all.

regrads,
Mac2004
Post 25 Feb 2007, 21:17
View user's profile Send private message Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Hi Mac2004, seem to work ok for me, how many times did you try ?.
Post 25 Feb 2007, 23:10
View user's profile Send private message Reply with quote
rugxulo



Joined: 09 Aug 2005
Posts: 2341
Location: Usono (aka, USA)
rugxulo
Quote:

Welcome to DexOS test page.
This is running on DexOS Server, which is running on the DexOS OS
A world first, coded by team DexOS
Cool ;)
Post 26 Feb 2007, 00:55
View user's profile Send private message Visit poster's website Reply with quote
Mac2004



Joined: 15 Dec 2003
Posts: 313
Mac2004
I tried a couple of times and now I'am trying again...

Regards
Mac2004
Post 26 Feb 2007, 04:59
View user's profile Send private message Reply with quote
Mac2004



Joined: 15 Dec 2003
Posts: 313
Mac2004
After long waiting i managed to get the response from the server.... Very Happy

regards
Mac2004
Post 26 Feb 2007, 05:24
View user's profile Send private message Reply with quote
Adam Kachwalla



Joined: 01 Apr 2006
Posts: 150
Adam Kachwalla
Try not to put too many features in it. Microsoft made that stupid mistake and now their Windows Server OS is very insecure. The more features, the more bugs to correct. That's why Windows Server "Longhorn" can be installed without a shell!
Post 25 Apr 2007, 08:41
View user's profile Send private message Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Sure that one of the main goals of DexOS, to keep it small and simple, but it a bit slow (the stack ) at the moment, so i am moding some key bits.
Post 25 Apr 2007, 15:12
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.