flat assembler
Message board for the users of flat assembler.

Index > Windows > MP3/MPEG Streaming Server in FASM by ME (finished!)


Is it interesting?
Yes
84%
 84%  [ 11 ]
No
15%
 15%  [ 2 ]
Total Votes : 13

Author
Thread Post new topic Reply to topic
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
Hello,
a few days ago i beginned programming a streaming server in fasm. It's designed for the player Winamp. It sends ICY TrackInfo Bitrate etc. and everything is working. Currently it plays mp3's upto 800MB Very Happy
I programmed it because I were interested in programming
my own Streamer.

AND IT WORKS Laughing

If you want to test it or see it in action, tell me
and i will upload it.
Post 06 Oct 2006, 23:15
View user's profile Send private message Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
Here it is:

http://netbone.ath.cx/dev/stream.exe

ToDo:
1. Start exe..
2. A char should blink on the console.. (forever)
3. Rename your MP3 to audio.strm
4. Conntect with Winamp to http://YourIP:39
Post 10 Oct 2006, 05:36
View user's profile Send private message Reply with quote
vid
Verbosity in development


Joined: 05 Sep 2003
Posts: 7105
Location: Slovakia
vid
nothing is blinking a i don't know which MP3 to rename.

could you also publish your source?
Post 10 Oct 2006, 07:21
View user's profile Send private message Visit poster's website AIM Address MSN Messenger ICQ Number Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
Source attached
if you have some Ideas to make it better.. do it Very Happy


Description:
Download
Filename: source.zip
Filesize: 1.96 KB
Downloaded: 113 Time(s)

Post 10 Oct 2006, 10:24
View user's profile Send private message Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
PS: I know its not professionally programmed. but it works.. was only some fun programming this..
Post 10 Oct 2006, 10:25
View user's profile Send private message Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
hey vid..
and what do you think? Very Happy
Post 10 Oct 2006, 17:34
View user's profile Send private message Reply with quote
vid
Verbosity in development


Joined: 05 Sep 2003
Posts: 7105
Location: Slovakia
vid
can't get it work...
Post 10 Oct 2006, 18:43
View user's profile Send private message Visit poster's website AIM Address MSN Messenger ICQ Number Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
I wonder.
Already tested on fresh installed 98se and 2000 XP and works! Here is a screenshot:

Image
Image


Last edited by sylwek32 on 10 Oct 2006, 19:30; edited 1 time in total
Post 10 Oct 2006, 19:23
View user's profile Send private message Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
do you have these three files in the folder and port 39 open ? (check port with tcpview)

Image
Post 10 Oct 2006, 19:27
View user's profile Send private message Reply with quote
sylwek32



Joined: 27 Apr 2006
Posts: 339
sylwek32
no more interesting? Very Happy
Post 11 Oct 2006, 11:23
View user's profile Send private message Reply with quote
cod3b453



Joined: 25 Aug 2004
Posts: 619
cod3b453
I got "Error syncing to mpeg" Confused (on WinME)
Post 17 Oct 2006, 10:47
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.