flat assembler
Message board for the users of flat assembler.

Index > OS Construction > problem with VESA mode 112h

Author
Thread Post new topic Reply to topic
zhak



Joined: 12 Apr 2005
Posts: 490
Location: Belarus
zhak
Hi people. I need help. I tried hard to display a .BMP by copying it to video memory. I use VESA Mode 112h. But when I move window by using function 4F05h of INT 10h then next portion of the image is shifted to the right. And I can't align it on the screen.
Why is it happen so? Thanks.
Post 28 Mar 2006, 21:17
View user's profile Send private message Reply with quote
zhak



Joined: 12 Apr 2005
Posts: 490
Location: Belarus
zhak
At last!!! I did it!
My mistake was that I didn't check granularity and window size.
VESA reports WinGranularity = 10000h bytes; BytesPerScanLine = 780h bytes, so I can write 34 lines in one window. It will occupy 0FF00h bytes.
I have 100h more bytes that i had to count. That is why the image was shifted and colors were mixed!!
Post 28 Mar 2006, 22:58
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.