flat assembler
Message board for the users of flat assembler.

Index > IDE Development > Language problem with editor

Author
Thread Post new topic Reply to topic
Big Red



Joined: 25 Feb 2005
Posts: 43
Big Red 19 Jan 2006, 18:36
Hi,

I often use FASMW.exe to write french comments in my files, but unlike Notepad/Wordperfect/Whatever, the editor doesn't combine some of the characters properly. If you set your keyboar to "Canadian French" (not "Legacy"), typically, pressing the
`
key followed by the
e
key should produce
è
However, fasmw.exe doesn't wait for the second character and puts
`
directly. It makes writing in french harder. Any way this could be fixed?

Thanks
Post 19 Jan 2006, 18:36
View user's profile Send private message Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 8346
Location: Kraków, Poland
Tomasz Grysztar 19 Jan 2006, 18:46
It was implemented as intended behavior, I've done like this because with Polish keyboard after pressing ~ you have to press second key to produce one of the Polish-specific letters (or space to write just ~) and I don't like this behavior when programming (perhaps mainly because of my habits from the DOS). For his reason my edit control doesn't allow such key combinations (and is pure x-ASCII, BTW).
Post 19 Jan 2006, 18:46
View user's profile Send private message Visit poster's website Reply with quote
Big Red



Joined: 25 Feb 2005
Posts: 43
Big Red 19 Jan 2006, 18:50
Okay, thanks anyway
Post 19 Jan 2006, 18:50
View user's profile Send private message Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 8346
Location: Kraków, Poland
Tomasz Grysztar 19 Jan 2006, 19:44
Well, since it indeed may look like a bug for someone that actually - unlike me - needs the standard dead-key behaviour, I decided to implement it just as an option. The FASMW interface 0.93.3 has it as an "Revive dead keys" option, by default disabled. So I can just enable this option in my FASMW to keep myself satisfied, and others can have just standard Windows behaviour on dead keys.
Post 19 Jan 2006, 19:44
View user's profile Send private message Visit poster's website Reply with quote
RedGhost



Joined: 18 May 2005
Posts: 443
Location: BC, Canada
RedGhost 20 Jan 2006, 02:21
hold alt and then press in order numpad: "0,2,3,3"

and it produces é, and works in FASMW

_________________
redghost.ca
Post 20 Jan 2006, 02:21
View user's profile Send private message AIM Address MSN Messenger Reply with quote
Big Red



Joined: 25 Feb 2005
Posts: 43
Big Red 09 Feb 2006, 18:42
Quote:

Well, since it indeed may look like a bug for someone that actually - unlike me - needs the standard dead-key behaviour, I decided to implement it just as an option. The FASMW interface 0.93.3 has it as an "Revive dead keys" option, by default disabled. So I can just enable this option in my FASMW to keep myself satisfied, and others can have just standard Windows behaviour on dead keys.


Thank you, this will save me alot of time. I also tend to use the editor for non-programming purposes (it's better than a lot of others).

Quote:

hold alt and then press in order numpad: "0,2,3,3"

and it produces é, and works in FASMW


Yes, I know that of course... but typing ALT0223 for every é character when you have pages full of them isn't the greatest thing.
Post 09 Feb 2006, 18:42
View user's profile Send private message Reply with quote
Madis731



Joined: 25 Sep 2003
Posts: 2139
Location: Estonia
Madis731 10 Feb 2006, 07:58
I had language problems too a while ago, but I thought that all the strange characters (õ,ä,ö,ü,š,ž,...) might produce unexpected results and therefore I won't use Estonian much in programming. ASCII limit suits fine.
Post 10 Feb 2006, 07:58
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 8346
Location: Kraków, Poland
Tomasz Grysztar 10 Feb 2006, 08:23
fasm itself treats each character in 128-255 range as a part of label name.
Post 10 Feb 2006, 08:23
View user's profile Send private message Visit poster's website Reply with quote
Big Red



Joined: 25 Feb 2005
Posts: 43
Big Red 10 Feb 2006, 14:50
Ah, it works perfectly now. Thanks again.

I never bother using foreign characters in code either. But I do in comments and such.
Post 10 Feb 2006, 14:50
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2024, Tomasz Grysztar. Also on GitHub, YouTube.

Website powered by rwasa.