flat assembler
Message board for the users of flat assembler.

Index > Macroinstructions > encoding macro

Author
Thread Post new topic Reply to topic
dr_dred



Joined: 29 May 2005
Posts: 5
Location: Earth
dr_dred
I can't compile this code:
Code:
include 'win32wxp.inc'
include 'encoding\win....inc'
start:
.loclab:
;...
invoke MessageBox, 0, "Test string", 0, 0
;...
jmp     .loclab
.end    start    


May be a global labels?
Post 14 Feb 2006, 13:18
View user's profile Send private message Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 7721
Location: Kraków, Poland
Tomasz Grysztar
Right, this is because of "data" label. It needs to be changed to "..data".
Post 14 Feb 2006, 13:37
View user's profile Send private message Visit poster's website Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 7721
Location: Kraków, Poland
Tomasz Grysztar
I updated latest fasmw with the fix.
Post 14 Feb 2006, 17:52
View user's profile Send private message Visit poster's website Reply with quote
dr_dred



Joined: 29 May 2005
Posts: 5
Location: Earth
dr_dred
Thanks
Post 15 Feb 2006, 12:30
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.