flat assembler
Message board for the users of flat assembler.

Index > Main > FASM 1.63 Bug, MOVQ encoding

Author
Thread Post new topic Reply to topic
r22



Joined: 27 Dec 2004
Posts: 805
r22
FASM:
section '.code' code readable executable
start:
movq qword[eax],xmm3
movq xmm4,qword[eax]

DECOMPILE:
.code:00402000 public start
.code:00402000 start proc near
.code:00402000 movq xmm3, xmm0
.code:00402004 movq qword ptr [eax], xmm4

Using XMMX registers with MOVQ seems to cause this bug.
Post 23 Jul 2005, 20:27
View user's profile Send private message AIM Address Yahoo Messenger Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17658
Location: In your JS exploiting you and your system
revolution
Code:
use32
movq qword[eax],xmm3 ;66-0f-d6-18
movq xmm4,qword[eax] ;f3-0f-7e-20    

Works correctly for me. What disassembler are you using?
Post 24 Jul 2005, 01:13
View user's profile Send private message Visit poster's website Reply with quote
r22



Joined: 27 Dec 2004
Posts: 805
r22
ida4.5 and ollydbg.
Odd I assume your using the newest release too revolution?
Post 24 Jul 2005, 01:43
View user's profile Send private message AIM Address Yahoo Messenger Reply with quote
comrade



Joined: 16 Jun 2003
Posts: 1137
Location: Russian Federation
comrade
Tomasz sometimes puts a version out, and makes a quick fix to it without changing the version number. Try the downloading FASM again from the website.
Post 24 Jul 2005, 04:25
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
comrade



Joined: 16 Jun 2003
Posts: 1137
Location: Russian Federation
comrade
The issue is present in an older version, 1.52, too though.
Post 24 Jul 2005, 04:26
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17658
Location: In your JS exploiting you and your system
revolution
I think you need a new debugger/disassembler. FASM 1.63.1 does the correct job.
Post 24 Jul 2005, 05:28
View user's profile Send private message Visit poster's website Reply with quote
comrade



Joined: 16 Jun 2003
Posts: 1137
Location: Russian Federation
comrade
His debugger and disassembler are fine. He needs newer FASM vervsion
Post 24 Jul 2005, 15:17
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17658
Location: In your JS exploiting you and your system
revolution
My Ollydbg v1.10d does not support SSE2/SSE3. Is there a later version already?
Post 25 Jul 2005, 01:55
View user's profile Send private message Visit poster's website Reply with quote
Reverend



Joined: 24 Aug 2004
Posts: 408
Location: Poland
Reverend
Afaik, v1.10d is the latest release from 1.x family. The next release will be v2.0
Post 26 Jul 2005, 14:03
View user's profile Send private message Visit poster's website Reply with quote
Mad_Overclocker



Joined: 11 Jan 2005
Posts: 20
Location: France,Earth
Mad_Overclocker
Post 27 Jul 2005, 00:18
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.