flat assembler
Message board for the users of flat assembler.

Index > MenuetOS > Freeze with PS/2 Keyboard and Mouse

Author
Thread Post new topic Reply to topic
comrade



Joined: 16 Jun 2003
Posts: 1137
Location: Russian Federation
comrade
I have a PS/2 Keyboard and Mouse.
When I try to start MenuetOS from floppy (from menuetos.org), it hangs at the blackscreen where it says "Press ESC to start". However, if I disconnect my mouse, it starts fine, but then I only have keyboard. I can take another mouse, serial COM1, and all works fine. But both PS/2 keyboard and PS/2 mouse hang.

My system:
CPU: Pentium IV Northwood 1.8GHz
Mainboard: ASUS P4XP-X
RAM: 512MB
Video: Radeon 9000 1280x1024

I can provide more information if anyone tells me how to get more information.

_________________
comrade (comrade64@live.com; http://comrade.ownz.com/)
Post 20 Jul 2005, 19:27
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
bogdanontanu



Joined: 07 Jan 2004
Posts: 403
Location: Sol. Earth. Europe. Romania. Bucuresti
bogdanontanu
It looks like some problems with enabling A20 line while a PS/2 device is attached. Try changing BIOS settings about emulation/legacy stuff maybe the BIOS is trying to emulate a PS/2 mouse/keyboard via USB with SMB code.

It happened to my SolarOS also with some laptops... Wink some return an extra byte or an extra IRQ or other data...

The more advanced stuff would be to try and debug the A20line enabling code...
Post 20 Jul 2005, 19:44
View user's profile Send private message Visit poster's website Reply with quote
comrade



Joined: 16 Jun 2003
Posts: 1137
Location: Russian Federation
comrade
i checked my BIOS and i did not find any such option
Post 21 Jul 2005, 03:43
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
Madis731



Joined: 25 Sep 2003
Posts: 2140
Location: Estonia
Madis731
Usually OS hangs with PS/2 when motherboard is starting to deteriorate (was that the right word) so check your capacitors - if they are like inflated then put your MoBo in the fridge or buy a set of new capacitors Razz ($10x6 or x8 ).
I cracked my brain reinstalling XP and blaiming on programs and patches until I figured this out. Sometimes works - other times its just fine Neutral. Maybe its the fault of MenuetOS or ASUS board's incompatibility, but usually its hardware.

BTW, you have 512 posts Very HappyVery HappyVery Happy
Dare you answer me and you must answer yet another 512 timest to get 1024 Very Happy
Post 22 Jul 2005, 18:45
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on YouTube, Twitter.

Website powered by rwasa.