flat assembler
Message board for the users of flat assembler.

Index > Main > Trouble Parsing Input

Author
Thread Post new topic Reply to topic
Llama Boy



Joined: 24 Jul 2005
Posts: 7
Location: Texas, USA
Llama Boy
I am working on a command line for an OS, working from scratch never seemed so hard. Ive only been programming for like 2weeks in assembler, so this is prolly very wrong. But here is the code

Code:
get_cmd proc near
    push ax
    push si
next_in:
    mov ah,0
    int 16h
    cmp al, 13
    je got_cmd
    mov [si],al
    inc si
    jmp next_in
got_cmd:
cmp si, cls
je clear_scr

jmp done_cmd

clear_scr:
call clear_screen
jmp done_cmd

done_cmd:
pop si
pop ax

ret
get_cmd endp    


cls is
cls db 'clear',0

I know why it isn't working, but how could i make it read the word as a byte?

_________________
Image
donut < llama < az
http://llama.computerboffin.com/ <-signup
http://llama.computerboffin.com/dotvs/
Post 01 Aug 2005, 17:29
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on YouTube, Twitter.

Website powered by rwasa.