flat assembler
Message board for the users of flat assembler.

Index > Compiler Internals > custom resource bug

Author
Thread Post new topic Reply to topic
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav 14 Apr 2005, 09:52
see included source


Description:
Download
Filename: resbug.rar
Filesize: 3.8 KB
Downloaded: 691 Time(s)


_________________
[not enough memory]
Post 14 Apr 2005, 09:52
View user's profile Send private message Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav 14 Apr 2005, 09:55
liitle comments: in resource script file i have ONE directory with custom resources, but after compilling main.asm i saw that i have TWO directories with the same name. I tryes it on different resource compillers, it seems that is a bug in fasm
Post 14 Apr 2005, 09:55
View user's profile Send private message Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav 18 Apr 2005, 11:49
hmm, no comments, i am ignored?
Post 18 Apr 2005, 11:49
View user's profile Send private message Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3499
Location: Bulgaria
JohnFound 18 Apr 2005, 13:41
You are using not standard name (coded with number) for your resource directory, but the directory name coded with string in the .res file.
You have to wait for Privalov to check whether this is bug or not.
As a workaround I can suggest you to use "RCDATA" as a directory name - this is the standard resource type for such kind of data - it is processed properly by FASM.

Regards
Post 18 Apr 2005, 13:41
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav 18 Apr 2005, 16:41
thanks, i already using rcdata
Post 18 Apr 2005, 16:41
View user's profile Send private message Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 8105
Location: Kraków, Poland
Tomasz Grysztar 18 Apr 2005, 22:56
Yes, it is a bug, but I completely have no time right now to look into it better.
Post 18 Apr 2005, 22:56
View user's profile Send private message Visit poster's website Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 8105
Location: Kraków, Poland
Tomasz Grysztar 30 Apr 2005, 16:03
Fixed in 1.61.0 (see the bottom of Download page).
Post 30 Apr 2005, 16:03
View user's profile Send private message Visit poster's website Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav 10 May 2005, 13:43
thank you
Post 10 May 2005, 13:43
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2023, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.