flat assembler
Message board for the users of flat assembler.

Index > Compiler Internals > bug or not?

Author
Thread Post new topic Reply to topic
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav
why when i compile this code i have get error 'Undefined symbol' at jump to .test? it is normal? it seems problems with @exit label, when i comment this label program compiles very well

Code:
cmp     eax,0
jz      @exit
or eax,-1
jmp     .test
nop
@exit:
nop  
.test:
nop
    

_________________
[not enough memory]
Post 20 Mar 2005, 13:24
View user's profile Send private message Reply with quote
Ivan Poddubny



Joined: 21 Sep 2003
Posts: 32
Location: Yaroslavl, Russia
Ivan Poddubny
@exit is a global label.
".test" is accessible only between @exit and the next global label.
Post 20 Mar 2005, 15:03
View user's profile Send private message Visit poster's website Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 7724
Location: Kraków, Poland
Tomasz Grysztar
To be more specific: ".test:" defines the @exit.test label in this case.
Post 20 Mar 2005, 15:13
View user's profile Send private message Visit poster's website Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav
ok thanks, i forgot about that pretty fasm.pdf:

Quote:

...and it's name is attached to the name of last global label...
Post 20 Mar 2005, 15:18
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.