flat assembler
Message board for the users of flat assembler.
Index
> Main > Naming functions in the FASM Standard Library |
How should functions in the standard library be named? | ||||||||||||||||||||||||||||||||||||||||||
|
||||||||||||||||||||||||||||||||||||||||||
Total Votes : 24 |
Author |
|
crc 11 Jun 2005, 16:52
What form should function names use in the FASM Standard Library?
|
|||
11 Jun 2005, 16:52 |
|
crc 11 Jun 2005, 18:20
I wasn't aware that the naming rules would be significantly different. I assume that there will be a prefix for routine packs, so you might have math.squareRoot or math.square_root or whatever. But the naming rules for both macros and functions should be the same IMO.
|
|||
11 Jun 2005, 18:20 |
|
pelaillo 11 Jun 2005, 18:29
I remember the same sort of poll the last time we talk about standard lib here
|
|||
11 Jun 2005, 18:29 |
|
vid 11 Jun 2005, 22:31
i think procs should have different naming than macros. I personally prefer includeAllGlobals, because it's less typing, in include_all_globals, you have to push shift for each word (except first) anyway, and you also have to move hand to "-" key which is quite out-of-standard-position.
Anyway, i think this poll was made too soon, we haven't agreed even on starting the project yet, first we have to find people willing to code library. pelaillo: well, it is a serious question (asked too son i think but anyway) |
|||
11 Jun 2005, 22:31 |
|
Kain 12 Jun 2005, 03:03
I don't think this is the proper forum to be discussing the particulars of a FASM standard library, unless the goal is for it to be compiled into a library for linking with HLLs.
Perhaps further discussion should be moved to the "Main" forum. |
|||
12 Jun 2005, 03:03 |
|
decard 12 Jun 2005, 09:30
You're right, this topic should be moved to Main forum.
vid: why do you think that it is too soon for this poll? More people will be able to vote it this topic stays for longer. |
|||
12 Jun 2005, 09:30 |
|
vid 12 Jun 2005, 17:45
decard: there wasn't enough information told about it and i think many people vote withoout deeper knowledge of problem (eg. differencing names for macros and procs and variables, discussion about each possibility etc.)
|
|||
12 Jun 2005, 17:45 |
|
coconut 12 Jun 2005, 17:59
i vote everything be lowercase except constants, this is assembly not C
|
|||
12 Jun 2005, 17:59 |
|
vid 13 Jun 2005, 07:25
cocount: then you have to tap shift anyway for "_" and you also have to move your hand to "-" key. But anyway, it's everyone's chose.
|
|||
13 Jun 2005, 07:25 |
|
coconut 13 Jun 2005, 12:40
its not so much for typing quick as for readability, im just used to asm in lowercase. but whatever standard is chosen will be fine
|
|||
13 Jun 2005, 12:40 |
|
Madis731 13 Jun 2005, 13:00
I wouldn't worry about comfy typing or readability, but the most important fact is that stuff like:
Code: my_includes test_code_base would be too errorprone because you would have to raise your hand before typing the next word. I think you have had the same problem as many of us like writing first word of the sentence: ...end. HOping to reach... here I wasn't just quick enough so writing: include_all_Globals can lead to hard-to-find bugs. Did you notice the mistake? |
|||
13 Jun 2005, 13:00 |
|
coconut 13 Jun 2005, 16:07
what difference is it to have to shift anyways to capitilize letters? or type 0 or O characters right next to the - character
|
|||
13 Jun 2005, 16:07 |
|
vid 13 Jun 2005, 19:10
okay, let's leave "some_thing" then, i think votes are clear in this. Do you want me to keep track what we have agreed on for now?
|
|||
13 Jun 2005, 19:10 |
|
< Last Thread | Next Thread > |
Forum Rules:
|
Copyright © 1999-2024, Tomasz Grysztar. Also on GitHub, YouTube.
Website powered by rwasa.