flat assembler
Message board for the users of flat assembler.

Index > Windows > [solved] check for ZF flag with .if

Author
Thread Post new topic Reply to topic
extra_12345



Joined: 21 Apr 2020
Posts: 34
extra_12345 03 Jul 2024, 17:50
how can i check for ZF with .if operator?

.if SIGN? works fine but .if ZERO? doesn't works
Post 03 Jul 2024, 17:50
View user's profile Send private message Reply with quote
extra_12345



Joined: 21 Apr 2020
Posts: 34
extra_12345 03 Jul 2024, 19:02
Edit: I just figured it out, this thread can be removed,thanks.
Post 03 Jul 2024, 19:02
View user's profile Send private message Reply with quote
Ali.Z



Joined: 08 Jan 2018
Posts: 687
Ali.Z 05 Jul 2024, 09:25
why you didnt share the solution? it could help others in the future.

_________________
Asm For Wise Humans
Post 05 Jul 2024, 09:25
View user's profile Send private message Reply with quote
extra_12345



Joined: 21 Apr 2020
Posts: 34
extra_12345 15 Jul 2024, 11:28
Ali.Z wrote:
why you didnt share the solution? it could help others in the future.



if I remeber correctly I had typos in my code otherwise for example:

test al,1
.if ZERO?


works fine.
Post 15 Jul 2024, 11:28
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2024, Tomasz Grysztar. Also on GitHub, YouTube.

Website powered by rwasa.