flat assembler
Message board for the users of flat assembler.

Index > Windows > win8 CreateProcess < ShellExecute

Author
Thread Post new topic Reply to topic
edfed



Joined: 20 Feb 2006
Posts: 4237
Location: 2018
edfed
in a program running under win8, i call creatProcess, it don't work, i call ShellExecute, it works.

i run as admin under 8 , CreateProcess works.

then, CreateProcess seems to be more restrictive than ShellExecute to do the same kind of job...

Maybe Fasmw should stop using CreateProcess to run the programs now Smile
Post 27 Mar 2014, 10:10
View user's profile Send private message Visit poster's website Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17279
Location: In your JS exploiting you and your system
revolution
What is the error code you get? Just saying "it don't work" doesn't tell us what went wrong.


Last edited by revolution on 27 Mar 2014, 22:12; edited 1 time in total
Post 27 Mar 2014, 10:47
View user's profile Send private message Visit poster's website Reply with quote
edfed



Joined: 20 Feb 2006
Posts: 4237
Location: 2018
edfed
the machine that revealed this problem is off, tomorrow, i'll take some time to get its error message Smile
Post 27 Mar 2014, 16:52
View user's profile Send private message Visit poster's website Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on YouTube, Twitter.

Website powered by rwasa.