flat assembler
Message board for the users of flat assembler.

Index > Windows > fasmw editor 1.71.07 crash

Author
Thread Post new topic Reply to topic
nmake



Joined: 13 Sep 2012
Posts: 193
nmake
I don't know exactly why it stops working immediately after clicking an .asm file, it crashes every time. The source file is 51 KB large. It does not crash with any other source file that is below this size. Don't know what to do, I can't continue my project, it just won't load my source file without crashing. Guess I have to download the good old notepad++ meanwhile.

I don't have time to find the crash address, if I find it I will report it.
Post 07 Mar 2013, 09:21
View user's profile Send private message Reply with quote
bitRAKE



Joined: 21 Jul 2003
Posts: 3032
Location: vpcmipstrm
bitRAKE
Did you try the latest non-development build?
Post 07 Mar 2013, 09:35
View user's profile Send private message Visit poster's website Reply with quote
nmake



Joined: 13 Sep 2012
Posts: 193
nmake
The latest I've tried is 1.71.07
Post 07 Mar 2013, 09:55
View user's profile Send private message Reply with quote
bitRAKE



Joined: 21 Jul 2003
Posts: 3032
Location: vpcmipstrm
bitRAKE
That is a development build.

If it works in 1.70.03 then the error is the result of one of many recent changes.

_________________
¯\(°_o)/¯ unlicense.org
Post 07 Mar 2013, 09:57
View user's profile Send private message Visit poster's website Reply with quote
nmake



Joined: 13 Sep 2012
Posts: 193
nmake
Maybe I messed up, I did a reboot and now it works. Can't tell what is the problem, my hardware is good, it's a brand new computer. Perhaps it wasn't fasmw after all because it seems to work now. I will tell if it happens again.
Post 07 Mar 2013, 10:00
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17658
Location: In your JS exploiting you and your system
revolution
nmake wrote:
... my hardware is good, it's a brand new computer.
I hope you are right, but don't be so sure your hardware is good just because it is new. Try running a few stress testing programs to verify. Memtest86 and Prime95 is a well respected tools for such a thing.
Post 07 Mar 2013, 10:34
View user's profile Send private message Visit poster's website Reply with quote
idle



Joined: 06 Jan 2011
Posts: 360
Location: Ukraine
idle
i met software crashes when VirtualBox was run
it stopped after reboot only
Post 08 Mar 2013, 10:41
View user's profile Send private message Reply with quote
khatch



Joined: 24 Oct 2011
Posts: 68
khatch
Hello;
Maybe it was because you downloaded some windows updates and your system was unstable because after downloading some system updates , you MUST reboot the system (in fact that happened to me with some program and when opened it in ollydbg I found the api calls changed in order BUT after i rebooted the system EVERYTHING returned NORMAL)

_________________
Jesus Christ is our Savior
Post 11 Mar 2013, 10:44
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.