flat assembler
Message board for the users of flat assembler.

Index > IDE Development > Error: invalid argument

Author
Thread Post new topic Reply to topic
int80



Joined: 25 Mar 2013
Posts: 3
int80
I have started using newide. I am new to FASM and FASMIDE. While trying to assemble a 16bit (MZ exe format) code, I get the message "Error: invalid argument." at the 'entry code:start' line.
Post 25 Mar 2013, 11:51
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17628
Location: In your JS exploiting you and your system
revolution
You will need to show your code. We can't tell what you did from that one line.
Post 25 Mar 2013, 16:08
View user's profile Send private message Visit poster's website Reply with quote
int80



Joined: 25 Mar 2013
Posts: 3
int80
revolution, thanks for the response. the moment, you asked me to post the code, i went and re-checked the code again and the error was popped because of silly mistake.

i was trying this :
entry code:start
segment code
start:

where it is supposed to be like this :
entry .code:start
segment .code
start:
Post 26 Mar 2013, 03:40
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.