flat assembler
Message board for the users of flat assembler.

Index > Macroinstructions > problem with 64bit stdcall macro

Author
Thread Post new topic Reply to topic
madmatt



Joined: 07 Oct 2003
Posts: 1045
Location: Michigan, USA
madmatt
when I add this at the bottom of my 'proc64.inc' file:
Code:
prologue@proc equ static_rsp_prologue
epilogue@proc equ static_rsp_epilogue
close@proc equ static_rsp_close    


the stdcall macro gives me parameter count errors.
when I remove the above lines, the stdcall macro behaves as it should.
fixes?

_________________
Gimme a sledge hammer! I'LL FIX IT!
Post 20 Apr 2012, 18:25
View user's profile Send private message Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 7750
Location: Kraków, Poland
Tomasz Grysztar
Fix uploaded. The "assert" has to be used there instead of "err", because the condition depends on resolved variables.
Post 20 Apr 2012, 21:31
View user's profile Send private message Visit poster's website Reply with quote
madmatt



Joined: 07 Oct 2003
Posts: 1045
Location: Michigan, USA
madmatt
Thanks, that did it.
Post 21 Apr 2012, 00:00
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on YouTube, Twitter.

Website powered by rwasa.