flat assembler
Message board for the users of flat assembler.

Index > Compiler Internals > [Fixed in 1.69.49]Undefined defined symbols

Author
Thread Post new topic Reply to topic
Lurker



Joined: 07 Feb 2012
Posts: 6
Lurker
I use Linux x86_64
Code:
foo:
.start
      jmp .end        ;undefined symbol foo.end (does not work)
   jmp @f          ;undefined symbol @f (didn't work as downloaded, worked after assembling fasm)
@@:
.end:
     jmp .start      ;assembles fine
     jmp @b          ;assembles fine    


Last edited by Lurker on 25 Mar 2012, 15:01; edited 1 time in total
Post 23 Mar 2012, 13:15
View user's profile Send private message Reply with quote
AsmGuru62



Joined: 28 Jan 2004
Posts: 1418
Location: Toronto, Canada
AsmGuru62
Probably, because "@@:" is ending the scope of label "foo:".
Post 23 Mar 2012, 14:02
View user's profile Send private message Send e-mail Reply with quote
Lurker



Joined: 07 Feb 2012
Posts: 6
Lurker
Sorry, I didn't think through the example xD
Code:
foo:
        jmp .foo        ;undefined symbol foo.foo (does not work) 
.foo 
        jmp .foo        ;assembles fine     

Code:
        jmp @f          ;undefined symbol @f (didn't work as downloaded, worked after assembling fasm) 
@@: 
        jmp @b          ;assembles fine    
Post 23 Mar 2012, 14:11
View user's profile Send private message Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 7782
Location: Kraków, Poland
Tomasz Grysztar
This report is probably related to the unsuccessful experiment with changing the selection of error to display. I will upload the reverted version tomorrow.
Post 23 Mar 2012, 18:35
View user's profile Send private message Visit poster's website Reply with quote
Lurker



Joined: 07 Feb 2012
Posts: 6
Lurker
Thanks a lot, awesome job with fasm.
Post 23 Mar 2012, 19:05
View user's profile Send private message Reply with quote
LostCoder



Joined: 07 Mar 2012
Posts: 22
LostCoder
Version 1.69.48 for windows
Screenshots:
1. Everything ok.
2. Invalid instruction (sub ebx).
3. Duplicate labels.
In 2 and 3 screenshots fasm reports invalid entry label. And what is actually annoying is that when you write code at 1500 line, press Ctrl+F9 and it scrolls up to entry keyword, but error can be anywhere.

Image Image Image
Post 23 Mar 2012, 23:02
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.