flat assembler
Message board for the users of flat assembler.

Index > Windows > Detach Debugger Question.

Author
Thread Post new topic Reply to topic
Overflowz



Joined: 03 Sep 2010
Posts: 1046
Overflowz
Hello everyone, is there any way to detach debugger from process ? I had plugin in ollydbg that was detaching it from process without process halt.. Does anybody knows how to do it ? Thanks.
Post 05 Sep 2011, 00:14
View user's profile Send private message Reply with quote
typedef



Joined: 25 Jul 2010
Posts: 2913
Location: 0x77760000
typedef
Look in the Windows API documentation where you found the other API you used before.
Post 05 Sep 2011, 00:30
View user's profile Send private message Reply with quote
Overflowz



Joined: 03 Sep 2010
Posts: 1046
Overflowz
Tried already but I can't find none. I found DebugActiveProcessStop but ollydbg fails on that API call + program too ofc. It even don't recognizes it -.- try yourself.
Post 05 Sep 2011, 01:37
View user's profile Send private message Reply with quote
Overflowz



Joined: 03 Sep 2010
Posts: 1046
Overflowz
I did it, never mind. Razz
Post 05 Sep 2011, 01:57
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17620
Location: In your JS exploiting you and your system
revolution
Overflowz wrote:
Hello everyone, is there any way to detach debugger from process ? I had plugin in ollydbg that was detaching it from process without process halt.. Does anybody knows how to do it ? Thanks.
Use google to find the answer. I have searched this before and there is a way, but it is tricky and complicated, and I forget how it works now. So rather than me search and do the work for you it is better if you search and do the work for yourself.
Post 05 Sep 2011, 02:52
View user's profile Send private message Visit poster's website Reply with quote
Overflowz



Joined: 03 Sep 2010
Posts: 1046
Overflowz
revolution
Because of my poor English skills, I am failing to search true results what I want. Before I posted this, I was searching this more than 2 hours but with no result and thanks to my nerves, I posted it here. I'm not posting anything "on air". First, I'm trying to search, and then posting. I don't see any problems here.
Post 05 Sep 2011, 03:21
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.