flat assembler
Message board for the users of flat assembler.

Index > Compiler Internals > Fixups and Windows 9x (solved)

Author
Thread Post new topic Reply to topic
SFeLi



Joined: 03 Nov 2004
Posts: 140
SFeLi
DLL example doesn't work on 9x. The problem is that fasm generates an empty fixup block in ERRORMSG.DLL (when imports are put into the separate section?):
Code:
VirtualAddress:  0x00001000
SizeOfBlock:     0x00000010 (0x0004 entries)
  0x00001028 HIGHLOW
  0x00001038 HIGHLOW
  0x00001041 HIGHLOW
  0x0000104E HIGHLOW
VirtualAddress:  0x00001000
SizeOfBlock:     0x00000008 (0x0000 entries)    

Windows 98 doesn't like the second block and doesn't apply fixups at all, however XP SP3 processes relocations without problems. As I understand this bug was introduced with 1.69.27. Is it possible to fix it?


Last edited by SFeLi on 09 Dec 2010, 13:00; edited 1 time in total
Post 09 Dec 2010, 10:41
View user's profile Send private message Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 7795
Location: Kraków, Poland
Tomasz Grysztar
Finally someone tested this. Wink Thanks for the report (it's corrected in 1.69.29).
Post 09 Dec 2010, 11:22
View user's profile Send private message Visit poster's website Reply with quote
SFeLi



Joined: 03 Nov 2004
Posts: 140
SFeLi
Thank you! Smile
Post 09 Dec 2010, 12:59
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.