flat assembler
Message board for the users of flat assembler.

Index > Macroinstructions > Can't use #?

Author
Thread Post new topic Reply to topic
Azu



Joined: 16 Dec 2008
Posts: 1160
Azu
Please help..

Code:
macro test prefix,[name,value,value1,value2]{
forward
prefix#name equ value
prefix#name#.1 equ value1
prefix#name#.2 equ value2
}
test Foo,<Bar,asdf,1,2>,<Bla,qwerty,blah,blaah>
if ~ FooBar.1 equ 1
   Error!
end if    



I keep getting
Quote:
prefix#name equ value
error: illegal instruction.

_________________
Post 07 Nov 2009, 03:32
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17271
Location: In your JS exploiting you and your system
revolution
Code:
macro test prefix,[name,value,value1,value2]{
forward
prefix#name equ value
prefix#name#.1 equ value1
prefix#name#.2 equ value2
}
test Foo,Bar,asdf,1,2,Bla,qwerty,blah,blaah
if ~ FooBar.1 eq 1
        Error!
end if    
Post 07 Nov 2009, 03:42
View user's profile Send private message Visit poster's website Reply with quote
Azu



Joined: 16 Dec 2008
Posts: 1160
Azu
Oops. Thank you Smile

_________________
Post 07 Nov 2009, 03:57
View user's profile Send private message Send e-mail AIM Address Yahoo Messenger MSN Messenger ICQ Number Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.