flat assembler
Message board for the users of flat assembler.

Index > Main > How should I set the path for include files?

Author
Thread Post new topic Reply to topic
shack



Joined: 19 Sep 2009
Posts: 6
shack
I typed from dos window "fasm layeredwin.asm".
then,

layeredwin.asm [9]
include "win32w.inc"
eror: filenot found

If I copy win32w.inc in the same directory as layeredwin.asm, it skips the error message,
but do I have to copy all the inc files in the working directory or put asm files in the fasmw folder?

Is there any way to set the path?

I set the path in the Environment variables(I am using windows XP) but it doesn't work.

How should I set the path for include files?

layeredwin.asm is a sample file,"trasparent window",http://flatassembler.net/examples.php.
Post 19 Sep 2009, 02:43
View user's profile Send private message Reply with quote
windwakr



Joined: 30 Jun 2004
Posts: 827
Location: Michigan, USA
windwakr
Firstly, welcome to the forums! It's always nice to see new people here.


Are you sure you set up the environment variable right? Here's an excerpt from this website on how to do it for FASM.

... wrote:

If you wish to use the Windows version of FASM, fasmw.exe (recommended), then go to "Start->Control Panels->System->Advanced->Environment Variables", and make a new system variable, called include, with the value c:\fasm\include. Now you are ready to run FASM.

Just replace "C:\fasm\include" with your fasm include directorys location.

I've attached a picture below of making the variable....Hmmm, now that I look at it, the circling of the "new" button looks VERY unneeded, almost like I'm saying "Hey dummy, this is the new button, durrr"....sorry if it comes across that way. I was just circling THAT new button and not the user one to show that you should create it under system......
Geeze, I've turned a simple reply into this mess.....I am no good at writing out good replies...




Ignore the below(not the picture, the text), it is only for FASMW. It seems you are just using the command prompt version...I should read posts all the way through before replying....:

If you have the latest version of FASM, I think it does it for you. But, if for some reason it doesn't work, add these to fasmw.ini(if it doesn't exist, make it).

[Environment]
Include = c:\fasmw168\include

Replace C:\... with your FASM include folders location.


Description:
Filesize: 26.05 KB
Viewed: 2310 Time(s)

environment_variable.png



_________________
----> * <---- My star, won HERE
Post 19 Sep 2009, 02:57
View user's profile Send private message Reply with quote
shack



Joined: 19 Sep 2009
Posts: 6
shack
Thanks!! You solved my problem!!

I didn't know the correct way for setting up the path,
I was typing in the "path",didn't make a new system variable.

Laughing
Post 19 Sep 2009, 04:40
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.