flat assembler
Message board for the users of flat assembler.

Index > Main > Weird Error

Author
Thread Post new topic Reply to topic
roticv



Joined: 19 Jun 2003
Posts: 374
Location: Singapore
roticv
When I add the following into my code I get,
Code:
proc Extractcontact, edsfds
     mov       eax, [edsfds]
        return  
    

An error "Invalid value" at jz bad_hostname whereby it would assemble fine if I did remove the above code. So what did I do wrong? Also I having a hard time trying to make use of local variables. the assembler kept giving me weird error that I could not stand it and use a global variable.

Do tell me what I did wrong.
Post 10 Feb 2004, 13:45
View user's profile Send private message Visit poster's website MSN Messenger Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3502
Location: Bulgaria
JohnFound
It should be:
Code:
proc Extractcontact, edsfds
     enter
     mov       eax, [edsfds]
     return  
    

And everything should be OK.

Regards.
Post 10 Feb 2004, 13:57
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
roticv



Joined: 19 Jun 2003
Posts: 374
Location: Singapore
roticv
Thanks. A stupid mistake on my part.. Embarassed
Post 10 Feb 2004, 14:02
View user's profile Send private message Visit poster's website MSN Messenger Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.