flat assembler
Message board for the users of flat assembler.

Index > Main > format binary + jmp

Author
Thread Post new topic Reply to topic
okasvi



Joined: 18 Aug 2005
Posts: 382
Location: Finland
okasvi
Why does this:
Code:
format binary
  jmp   [ASD]
  ASD   dd 0    

assemble into FF 2E 04 00 00 00 00 00
atleast Ollydbg and hexplorer show FF 2E = jmp [esi] Confused

or is this expected behaviour?

_________________
When We Ride On Our Enemies
support reverse smileys |:
Post 21 Aug 2006, 14:13
View user's profile Send private message MSN Messenger Reply with quote
Tomasz Grysztar



Joined: 16 Jun 2003
Posts: 7802
Location: Kraków, Poland
Tomasz Grysztar
You forgot that fasm's default is "use16", not "use32". Wink
Post 21 Aug 2006, 14:16
View user's profile Send private message Visit poster's website Reply with quote
okasvi



Joined: 18 Aug 2005
Posts: 382
Location: Finland
okasvi
oic, thanks Very Happy
Post 21 Aug 2006, 15:11
View user's profile Send private message MSN Messenger Reply with quote
RedGhost



Joined: 18 May 2005
Posts: 443
Location: BC, Canada
RedGhost
You can just skip the format binary and have 'use32' because fasm defaults to binary/use16.

_________________
redghost.ca
Post 22 Aug 2006, 05:11
View user's profile Send private message AIM Address MSN Messenger Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.