flat assembler
Message board for the users of flat assembler.

Index > Windows > Setting up vc++ debugger for fasm

Author
Thread Post new topic Reply to topic
system error



Joined: 01 Sep 2013
Posts: 671
system error
I don't know how to exactly state the problem. But in my old PC, the vc++ debugging window will always come up whenever I tried to assemble a faulty asm code. Now I am on a new pc, Win7 (32-bit) dual boot (linux 64-bit). I already installed vc++ and the stuff. I try to run a faulty fasm code but what keeps popping up is that silly "Windows looking for solution.." thingy. what to do??
Post 20 Oct 2014, 05:54
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17620
Location: In your JS exploiting you and your system
revolution
You need to tell VC to register as a JIT debugger. Maybe there is an option somewhere that says "Use VC as a JIT debugger"? Once a program registers as a JIT debugger then you don't get the Windows dialog box anymore, it jumps directly to the registered program.


Last edited by revolution on 20 Oct 2014, 13:45; edited 1 time in total
Post 20 Oct 2014, 06:48
View user's profile Send private message Visit poster's website Reply with quote
system error



Joined: 01 Sep 2013
Posts: 671
system error
Yeah, i recall something about the JIT. But there's only 1 checkbox for JIT under "Tools>Options>Debugging" and under "Debug>options & setting" (VC++ Express 2010). It says "Suppress JIT optimization on Module load (Managed only)". I enabled it. Still don't work... kinda convenient when that debugger says hello each time I try to compile/run a faulty fasm code. kinda miss it. Btw, there are already 4 vc++ redistributables (2005,2008,2008 and 2010) on the system. Should I reinstall them all?


Last edited by system error on 20 Oct 2014, 12:51; edited 1 time in total
Post 20 Oct 2014, 12:47
View user's profile Send private message Reply with quote
system error



Joined: 01 Sep 2013
Posts: 671
system error
Or is it something about the File Association?
Post 20 Oct 2014, 12:50
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 17620
Location: In your JS exploiting you and your system
revolution
system error wrote:
Or is it something about the File Association?
No. It is fully controlled by the debugger application. For example Ollydbg can set and unset itself for JIT without a problem in Win7.
Post 20 Oct 2014, 13:13
View user's profile Send private message Visit poster's website Reply with quote
system error



Joined: 01 Sep 2013
Posts: 671
system error
I am downloading vc++ 2012 express now. There is no JIT options for the 2010 version. But I am not sure anymore. LOL. Last time I did use 2010 express on my XP. I am pretty sure it was 2010. Will come back with the result. Olly is good. But it hurts my eyes Razz
Post 20 Oct 2014, 13:35
View user's profile Send private message Reply with quote
AsmGuru62



Joined: 28 Jan 2004
Posts: 1416
Location: Toronto, Canada
AsmGuru62
You can set up the bigger fonts in Olly.
Smile
Post 20 Oct 2014, 16:29
View user's profile Send private message Send e-mail Reply with quote
typedef



Joined: 25 Jul 2010
Posts: 2913
Location: 0x77760000
typedef
system error wrote:
There is no JIT options for the 2010 version


Tools >> Options >> Debugging >> Just-In-Time
Post 21 Oct 2014, 01:51
View user's profile Send private message Reply with quote
system error



Joined: 01 Sep 2013
Posts: 671
system error
AsmGuru62 wrote:
You can set up the bigger fonts in Olly.
Smile
That's the only option I have for now. Are u Oleh Yuschuk? No offence. OllyDbg is GREAT. It's just a matter of familiarity on my part.
Post 22 Oct 2014, 07:54
View user's profile Send private message Reply with quote
system error



Joined: 01 Sep 2013
Posts: 671
system error
typedef wrote:
system error wrote:
There is no JIT options for the 2010 version


Tools >> Options >> Debugging >> Just-In-Time
No such luck. VS Express 2012 doesn't have such options under "Debugging".
Post 22 Oct 2014, 07:56
View user's profile Send private message Reply with quote
AsmGuru62



Joined: 28 Jan 2004
Posts: 1416
Location: Toronto, Canada
AsmGuru62
I am not Oleh.
Just a long time OllyDbg user.
Post 22 Oct 2014, 15:21
View user's profile Send private message Send e-mail Reply with quote
typedef



Joined: 25 Jul 2010
Posts: 2913
Location: 0x77760000
typedef
system error wrote:
typedef wrote:
system error wrote:
There is no JIT options for the 2010 version


Tools >> Options >> Debugging >> Just-In-Time
No such luck. VS Express 2012 doesn't have such options under "Debugging".


That's for Visual studio 2010.
Post 23 Oct 2014, 04:19
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.