flat assembler
Message board for the users of flat assembler.

Index > IDE Development > FASMW under WIN7 - file access

Author
Thread Post new topic Reply to topic
shutdownall



Joined: 02 Apr 2010
Posts: 518
Location: Munich
shutdownall
Today it's the first time using FASMW.EXE under WIN7.
Did use WIN XP in the past only.

Are there any issues regarding file access ???
The behaviour is strange.

Whenever I open an existing asm file, FASMW does not save the source automatically, ask me to use save as ... function. And asked me if I am sure to overwrite.

If I save the file under a new name, it's okay. Never ask again.
But when I want to change and recompile FASM source files this is not convenient.

The files have been copied from a WIN XP partition (from other users space).
The files are not shown as write protected.

What could be the problem ?
And how to solve ?
Post 06 Dec 2012, 22:06
View user's profile Send private message Send e-mail Reply with quote
cod3b453



Joined: 25 Aug 2004
Posts: 619
cod3b453
I've had problems with fasmw (and other applications) under program files (or any system directory). Win 7 doesn't like files being modified there; I've even ended up with two copies of the same file but with different visibilities. The only way round it was to copy the source to somewhere less protected, assemble and copy the binary back.

Hope that helps
Post 06 Dec 2012, 22:47
View user's profile Send private message Reply with quote
shutdownall



Joined: 02 Apr 2010
Posts: 518
Location: Munich
shutdownall
It's not somewhere in system area or under programs.
Have created a directory "develop" directly under C: and several subdirectories.

Could be more be a problem of some "hidden" file attributes I think.
Maybe could help to copy the files on a non-mft filesystem on a usb stick.
Didn't try out yet.

Now it's copied from a WIN XP partition on the same harddisk.
Could imagine WIN reads some attributes ...

Anybody experience like this ?
Post 06 Dec 2012, 23:51
View user's profile Send private message Send e-mail Reply with quote
shutdownall



Joined: 02 Apr 2010
Posts: 518
Location: Munich
shutdownall
Very strange behaviour.
Nobody else had problems with this ?

If I run FASMW with admin privileges (execute as admin) it works normal as under XP.
By the way I have here version 1.71 - so quite new.

After I changed the directory or file with full access privileges for all users and started FASMW again with no admin privileges. Same as before, if open existing FASMW.ASM and new compile it opens the "save as" dialog. But can confirm to overwrite the FASMW.ASM and it does.

If I open the same file with notepad, I can easily click on save. If I open again with FASMW it always open "save as" dialog.
So what the heck is going on ?

And does anybody know how I can add a program to the taskline at the bottom with additional "execute as admin" privileg ?
Post 07 Dec 2012, 13:46
View user's profile Send private message Send e-mail Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar. Also on GitHub, YouTube, Twitter.

Website powered by rwasa.