flat assembler
Message board for the users of flat assembler.

flat assembler > IDE Development > Fresh work version with "Source level debuger" :D

Goto page 1, 2, 3  Next
Author
Thread Post new topic Reply to topic
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
It is uploaded on the Fresh site with number: 1.0.1C.0f

Well, it is ridiculous for now, but the framework is almost ready, so we need only behaviour/appearance improvements.
Start it from: "project|Source debugger".

I need some tests on different plathforms, because there probably will be problems on NT/2000/XP machines.
Better test it with simple.asm or test.fpr from directory "examples".

Important (help needed): Now, after finishing debugging session, the debugged program terminates normally, but the exe file remains locked for write, so second compilation is impossible. It is unlocked only after closing Fresh. I close all handles to the threads and processes, but it not help at all. If someone know some solution to this problem, please, post some info.

Another useful feature is "Project|Goto address". It possitions the source editor on the line with given address. Great for working with external debuger. But it uses the same engine as debugger, so the similar problems may occur. This function needs compiling before it can find the line.

Please, provide feedback. It is important for future developement.

Regards.
Post 23 Jan 2004, 01:14
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
Tommy



Joined: 17 Jun 2003
Posts: 492
Location: Norway
Cool! (I have to test it when I get home from school, 'cause I'm not able to test it right now... but seems to be very good work again John!) BTW: just a little note: remember to write "debugger", not "debuger"... Wink

Cheers,
Tommy
Post 23 Jan 2004, 08:21
View user's profile Send private message Visit poster's website Reply with quote
decard



Joined: 11 Sep 2003
Posts: 1095
Location: Poland
Well I must say I'm impressed Very Happy. Debugger seems to fork fine in WinME. However, the package contains an executable, but it is older, so to see how does debugger work you have to recompile Fresh.

btw, I noticed that size of fresh.exe decreased Smile
Post 23 Jan 2004, 15:25
View user's profile Send private message Visit poster's website Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
decard wrote:
However, the package contains an executable, but it is older, so to see how does debugger work you have to recompile Fresh.


Sorry for that, I forget to change the executable. But I will leave it this way, because I will upload better version very soon. I only wait for some XP reports to be sure that it works under XP.

Regards.
Post 23 Jan 2004, 16:50
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
pelaillo
Missing in inaction


Joined: 19 Jun 2003
Posts: 865
Location: Colombia
You got it!!!
Congratulations JohnFound Exclamation

btw. Tested on an old Pentium 266 with win98 (fresh takes 37.45 sec to compile itself)
I will test at home later.
Post 23 Jan 2004, 18:17
View user's profile Send private message Yahoo Messenger Reply with quote
pelaillo
Missing in inaction


Joined: 19 Jun 2003
Posts: 865
Location: Colombia
It doesn't work properly on WinXP.
(properly in the sense of the Win98 tests)

There is sometimes the painting bug in editor:
It puts only the first character.
Post 24 Jan 2004, 17:04
View user's profile Send private message Yahoo Messenger Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
pelaillo wrote:
It doesn't work properly on WinXP.
(properly in the sense of the Win98 tests)


Well, I know that there is some bugs in WinXP and I am working on them, but what about debugger function? When you load (for example) the file: simple.asm and press Shift+F8, Fresh should compile the program, run it in debug mode and stop on the first instruction of the source, showing the message box with title: "Single step". Then on every [OK] it should step instruction by instruction to the end of the source.

Regards.
Post 24 Jan 2004, 17:12
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
ipadilla



Joined: 08 Sep 2003
Posts: 11
Hi JohnFound,

After Shift+F8, compilation is OK, but something is missing according to your explanation.

OS: Widows98 SE.

Regards
ipadilla


Description:
Filesize: 31.8 KB
Viewed: 2843 Time(s)

Screen00.jpg


Post 24 Jan 2004, 17:53
View user's profile Send private message Reply with quote
pelaillo
Missing in inaction


Joined: 19 Jun 2003
Posts: 865
Location: Colombia
JohnFound wrote:
what about debugger function?

I am currently studying your code to try to give some help with xp.
When the program (testProj) compiles, it stops in the first line and then it runs until the end without the stop.
The problem is probably with "WaitForDebugEvent" or "ContinueDebugEvent" now I am preparing an old computer with win98 to do a parallel to try to get where's the difference.

Regards,
pelaillo

p.s. I am puzzled about the editor bug. Sometimes I don't get the characters painted nor selectable.
Post 25 Jan 2004, 15:59
View user's profile Send private message Yahoo Messenger Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
Hi Pelaillo.
I am almost ready with next work version with a lot better user interface for debugger. I made big changes in the layout making some kind of debug "server" in separate thread. Maybe it will make things better in XP.
Anyway you help will be great, because I have no XP and I don't want to install one on my old computer.

Regards.
Post 25 Jan 2004, 17:56
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
Hi all.

I just uploaded new work version of Fresh with the second atempt for debugger. Very Happy
It is almost fully rewriten, so, now it have almost real "debugger" user interface. I tested it on my Win98.

Any help on debuging/fixing on WinXP is highly appreciated.

Regards.
Post 25 Jan 2004, 22:10
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
decard



Joined: 11 Sep 2003
Posts: 1095
Location: Poland
You have done a really good job Wink
But when running test.asm the debugger window shows one thing that I don't understand:
Code:
Exception:Breakpoint at $BFF66878
Exception:Breakpoint at $00401000    

Why there are two breakpoints while the code contains only one?
And after int3 it just "jumps" over the nop instruction.
Post 25 Jan 2004, 23:05
View user's profile Send private message Visit poster's website Reply with quote
Tommy



Joined: 17 Jun 2003
Posts: 492
Location: Norway
BTW: my component-toolbar doesn't load though the lib-path is set properly... Sad
Post 26 Jan 2004, 09:24
View user's profile Send private message Visit poster's website Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
New work version uploaded on the Fresh site. ( http://fresh.flatassembler.net ).
Filename is: FreshWork1_0_1C_12.rar

Well after some remote debugging, Me and Tommy fix the bug in Fresh debugger related to Win2000/XP. (Tommy was remote server, I was a client. Very Happy ) Now debugger should work. At least Tommy didn't provide bugreports anymore. Wink

Also, user interface for debbuger is changerd.
Please, send feedback. There are probably another bugs.


Regards.
Post 26 Jan 2004, 22:01
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
pelaillo
Missing in inaction


Joined: 19 Jun 2003
Posts: 865
Location: Colombia
Sorry my friend, here it isn't working but I like it very much the new appearance and interface.

There are still some bugs on editor:
1. Some lines aren't painting at all
2. Sometimes it doesn't paint the working area
3. The highlighting have some problems.

There are a bug on stop button. I clicked it by accident and fresh crashes (cpu get's 100%).

I´m working on them. Sorry but I go slow and you are so productive... Embarassed
Post 26 Jan 2004, 23:46
View user's profile Send private message Yahoo Messenger Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
Hi, pelaillo.
Thank you for the help. I think to stop debugging debugger, Smile because I still have no WinXP. So, any help with any speed from you is great. I will check some another features these days and I have to finish code completition.

Regards
Post 27 Jan 2004, 05:38
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
decard



Joined: 11 Sep 2003
Posts: 1095
Location: Poland
btw, CC list opens when you press '>' also.
Post 27 Jan 2004, 07:22
View user's profile Send private message Visit poster's website Reply with quote
JohnFound



Joined: 16 Jun 2003
Posts: 3494
Location: Bulgaria
Hi all.
I think I realize what is the problem on XP. It seems to be because of data missalignments. I post here the current exe. It work on one Win2000 computer. I hope it will work under WinXP too. Please someone to test it.

btw: Strange, but the debugger works very slow for me on Win2000.

Regards.

[EDIT] Removed outdated attachement. [/EDIT]
Look at the Fresh site for the latest version.


Last edited by JohnFound on 27 Jan 2004, 23:08; edited 2 times in total
Post 27 Jan 2004, 14:48
View user's profile Send private message Visit poster's website ICQ Number Reply with quote
Tommy



Joined: 17 Jun 2003
Posts: 492
Location: Norway
Hi John,

Good! In the last fix it seems like you've fixed both the bugs that I mentioned! Wink Superb! Maybe the debugger is a bit slow, yes, but if you hadn't mentioned it I would never found it out myself... Wink Keep up the good work... I'll test it a bit more and come with more feedback if necessary...

Cheers,
Tommy
Post 27 Jan 2004, 16:12
View user's profile Send private message Visit poster's website Reply with quote
Tommy



Joined: 17 Jun 2003
Posts: 492
Location: Norway
BTW: I noticed that when a DLL is loaded the only message that appears is "DLL loaded: "... Is this a bug, or haven't you implemented it fully yet?
Post 27 Jan 2004, 16:14
View user's profile Send private message Visit poster's website Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  
Goto page 1, 2, 3  Next

< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2019, Tomasz Grysztar.

Powered by rwasa.