flat assembler
Message board for the users of flat assembler.

Index > Heap > plz, need control testing (button)

Author
Thread Post new topic Reply to topic
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav
hello everybody

please, i need big help, i need this button to be tested on a various windows, great thanks

eg.:
winxpsp2 - works ok, button shows normal, image shows normal
win95 - doesn't work, button shows ugly, image doesn't shows

_________________
[not enough memory]


Last edited by Vasilev Vjacheslav on 10 Mar 2006, 05:59; edited 1 time in total
Post 05 Mar 2006, 10:56
View user's profile Send private message Reply with quote
vbVeryBeginner



Joined: 15 Aug 2004
Posts: 885
Location: \\world\asia\malaysia
vbVeryBeginner
hey vasilev vjacheslav,

nice button!

Image

running nlited winxp gold (no sp)
btw, if u got a pc with about 512 or more memory and a p3 or p4, u could consider vmware, (u could build many virtual pc inside) eg. win95, 98, 2k, xp and test them as u develop
Post 05 Mar 2006, 11:27
View user's profile Send private message Visit poster's website Reply with quote
RedGhost



Joined: 18 May 2005
Posts: 444
Location: BC, Canada
RedGhost
vbVeryBeginner wrote:
hey vasilev vjacheslav,

nice button!

Image

running nlited winxp gold (no sp)
btw, if u got a pc with about 512 or more memory and a p3 or p4, u could consider vmware, (u could build many virtual pc inside) eg. win95, 98, 2k, xp and test them as u develop


vmware is probably the best software i have ever used! (well besides fasm Smile)

_________________
redghost.ca
Post 05 Mar 2006, 12:01
View user's profile Send private message AIM Address MSN Messenger Reply with quote
flaith



Joined: 07 Feb 2005
Posts: 122
Location: $300:20 58 FC 60 N 300G => Vietnam
flaith
Sad Image
W2K SP4

_________________
Je suis sur de 'rien', mais je ne suis pas sur du 'tout'.
Post 05 Mar 2006, 15:42
View user's profile Send private message Visit poster's website Reply with quote
Madis731



Joined: 25 Sep 2003
Posts: 2145
Location: Estonia
Madis731
Yeah, it gets a read error with a TEST instruction in USER32 code on Win2K systems - maybe because you have not taken proper care of your pushes and pops Wink
But from the look of it - I'd like to get it to work on my Windows too Very Happy
Post 05 Mar 2006, 17:15
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger Reply with quote
OzzY



Joined: 19 Sep 2003
Posts: 1029
Location: Everywhere
OzzY
Works OK here on WinXP SP1.
Nice work! How do you create these buttons? I always wanted to create my own GUI with new buttons and all.

Thanks!
Post 05 Mar 2006, 17:20
View user's profile Send private message Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav
when i fix all bugs i suppose to release source code, now i have some free time

ps. downloading vwmare Smile
Post 05 Mar 2006, 18:14
View user's profile Send private message Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav
ok, i think, i fixed all bugs in control and i release source code soon

what i plan to release:
- fasm source
- c++/c source
- bmp support
- gif/jpg support (oleloadpicture)


Description: plz, test me on win2k
Download
Filename: control.rar
Filesize: 2.69 KB
Downloaded: 269 Time(s)


_________________
[not enough memory]
Post 10 Mar 2006, 05:58
View user's profile Send private message Reply with quote
veach1



Joined: 16 Jul 2004
Posts: 165
veach1
Quote:
plz, test me on win2k

working OK, looks nice
Post 10 Mar 2006, 07:47
View user's profile Send private message Reply with quote
Madis731



Joined: 25 Sep 2003
Posts: 2145
Location: Estonia
Madis731
Very Happy But the buttons are not as in the screenshots...
The first one is greyed out and the second one is red and clickable.

2K SP4
Post 10 Mar 2006, 09:00
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger Reply with quote
Vasilev Vjacheslav



Joined: 11 Aug 2004
Posts: 392
Vasilev Vjacheslav
Madis731, yes i know, it's because first button have WS_DISABLED style
Post 10 Mar 2006, 12:36
View user's profile Send private message Reply with quote
Reverend



Joined: 24 Aug 2004
Posts: 408
Location: Poland
Reverend
Win XP SP2
Works great and looks nice Wink
Post 10 Mar 2006, 19:39
View user's profile Send private message Visit poster's website Reply with quote
flaith



Joined: 07 Feb 2005
Posts: 122
Location: $300:20 58 FC 60 N 300G => Vietnam
flaith
Works ok in W2K now, thanks
but click on the button several times !

_________________
Je suis sur de 'rien', mais je ne suis pas sur du 'tout'.
Post 11 Mar 2006, 17:10
View user's profile Send private message Visit poster's website Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Copyright © 1999-2020, Tomasz Grysztar.

Powered by rwasa.