flat assembler
Message board for the users of flat assembler.

Index > DOS > Dos sound problems! Any1 to help

Author
Thread Post new topic Reply to topic
babylon6



Joined: 20 Sep 2005
Posts: 2
Location: Europe
babylon6
I have intel 815E motherboard with the ICH2 sound support pci... I am trying to get any available dos sound. Actually i would like to play my games, mainly MAME but not way i can set up the ICH2 with all the programs on the internet i have found to play MAME games as with soundblaster....
I tried the ichinit.com program and it says it detects the ICH AC97 but it is disabled in BIOS, which is not true as soon as i launch windows i have sound....

Any help on this guys...
Thanks
Post 20 Sep 2005, 20:17
View user's profile Send private message Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
I made a AC97 CD player, it is in the form of a bootable CLI cdplayer, with AC97 and fm801 + SB pro drives built in (it was a test for some drivers i made for my OS Dex4u).
You can try it, if it works with your card, i can show you how to enable SB compatibility so MAME will work.

The program in the zip is a program that put the program on a floppy, to boot it from,
you can put it on a floppy and boot it or you can run the com file that is put on the floppy from dos (not a dos box).

PS: The driver + cdplayer is only about 2k, it becasue it comes with a floppy image the zip is so big.


Description:
Download
Filename: AC97CdPlay.zip
Filesize: 590.89 KB
Downloaded: 176 Time(s)

Post 21 Sep 2005, 09:54
View user's profile Send private message Reply with quote
Octavio



Joined: 21 Jun 2003
Posts: 366
Location: Spain
Octavio
Dex4u wrote:
PS: The driver + cdplayer is only about 2k, it becasue it comes with a floppy image the zip is so big.

if the floppy is empty the compressed image should be smaller < 1KB.
is the source available?
Post 21 Sep 2005, 10:09
View user's profile Send private message Visit poster's website Reply with quote
Dex4u



Joined: 08 Feb 2005
Posts: 1601
Location: web
Dex4u
Your right if it was just a floppy image, but it must be some thing to do with the self extrating windows exe, made with "Winimage".

I do have the source some where on a back up CD for this realmode version if your interested, but it is not finished, as it only detects and unmute the sound and you can set SB pro bits enabled and volume + or - etc.
Post 21 Sep 2005, 10:47
View user's profile Send private message Reply with quote
babylon6



Joined: 20 Sep 2005
Posts: 2
Location: Europe
babylon6
Thanks a lot i will try it out... Oh i fixed the sound with help of advance mame... It is a funny thing that advancemame runs ok on windows, when i boot to msdos (i have win98se) there is no sound.. I made a bootable floppy and woualla there is sound under pure dos:) Twisted Evil I guess i will have to use my floppy all the time:)
Anyway i am wondering is there any Dos DVD/VCD/AVI/MP3 or any audio video format that would work on this board with the ICH2 channel?
Hey DEX4U, using the driver on your program would it make dos mame, not advance mame to work, coz advance mame has option of vsynch/ac97 sound, and dos mame has only soundblaster....
Thanks a lot people,
Esad
Post 21 Sep 2005, 20:22
View user's profile Send private message Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2019, Tomasz Grysztar.

Powered by rwasa.