flat assembler
Message board for the users of flat assembler.

flat assembler > IDE Development > [apparently no bug] Search (without Replace)

Author
Thread Post new topic Reply to topic
DOS386



Joined: 08 Dec 2006
Posts: 1904
Sorry for one more bug report of the wrong component but there is one more regression in the DOS IDE: Search without Replace for "whole word" deletes the found word


Last edited by DOS386 on 14 Jun 2009, 10:19; edited 1 time in total
Post 18 Apr 2009, 06:49
View user's profile Send private message Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 6999
Location: Kraków, Poland
I'm not sure, what do you mean exactly. Can you give detailed steps how to reproduce this bug?
Post 14 Jun 2009, 08:48
View user's profile Send private message Visit poster's website Reply with quote
DOS386



Joined: 08 Dec 2006
Posts: 1904
Thanks. Load some text, Search for some word (check "whole word") ... the found word is deleted instead selecting it ...
Post 14 Jun 2009, 09:30
View user's profile Send private message Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 6999
Location: Kraków, Poland
I tried this, but word doesn't get deleted (even if I turn off "secure selection"). Are you sure you don't use the "Replace" window instead of "Find"? Wink
Post 14 Jun 2009, 09:32
View user's profile Send private message Visit poster's website Reply with quote
DOS386



Joined: 08 Dec 2006
Posts: 1904
Maybe YES ... the evil thing is that I was waiting for a fix of a no-bug and the good that 1.68 can become a successful release without regressions ... I indeed can't reproduce it anymore, except by pushing CTL-G instead of CTL-F ... sorry Sad IIRC I had suggested to display something like "Replaced 23'456 occurrences" when CTL-G is done some time ago ... so this is probably the thing that probably bothers me most for now, so maybe you can look into it or I can try again Wink
Post 14 Jun 2009, 10:25
View user's profile Send private message Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 6999
Location: Kraków, Poland
That message should be an easy thing to do.
Post 14 Jun 2009, 10:41
View user's profile Send private message Visit poster's website Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >
Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Copyright © 1999-2018, Tomasz Grysztar.

Powered by rwasa.