flat assembler
Message board for the users of flat assembler.

flat assembler > Feedback > Conversion of TABs into SPACEs in messages changes alignment

Author
Thread Post new topic Reply to topic
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15860
Location: 162173 Ryugu
I noticed in this topic:

http://board.flatassembler.net/topic.php?t=12012

That the code sections have been changed from the original <tab> characters into <space> characters and now the columns are all out of alignment.

What causes this? And can it be turned off or fixed?
Post 01 Feb 2014, 16:38
View user's profile Send private message Visit poster's website Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15860
Location: 162173 Ryugu
This problem appears to affect a lot of older posts. Here is another example:

http://board.flatassembler.net/topic.php?p=93655#93655
Post 02 Feb 2014, 12:05
View user's profile Send private message Visit poster's website Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 6863
Location: Kraków, Poland
The function that processes the [code] blocks has not been changed in years. Maybe something works differently with the modern browsers? I'm shooting in the dark, I did not look for the underlying cause yet.
Post 02 Feb 2014, 12:58
View user's profile Send private message Visit poster's website Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15860
Location: 162173 Ryugu
I know that when they were posted the alignment was fine. But when I look back at those posts they have been changed. What were originally <tab> characters are now stored as multiple <space> characters instead.
Post 02 Feb 2014, 13:21
View user's profile Send private message Visit poster's website Reply with quote
Tomasz Grysztar
Assembly Artist


Joined: 16 Jun 2003
Posts: 6863
Location: Kraków, Poland
It is possible that restoring the database from backup has messed them up. But then it may not be easy to fix it automatically...
Post 02 Feb 2014, 13:24
View user's profile Send private message Visit poster's website Reply with quote
typedef



Joined: 25 Jul 2010
Posts: 2910
Location: 0x77760000
BB code parsers don't take TABs unless you use a bot because the tab key event is caught by the browser. Normally all known code parsers will use 4 spaces as a TAB.
Post 02 Feb 2014, 14:18
View user's profile Send private message Reply with quote
revolution
When all else fails, read the source


Joined: 24 Aug 2004
Posts: 15860
Location: 162173 Ryugu
typedef wrote:
BB code parsers ...
Do you mean browser input boxes?
typedef wrote:
... don't take TABs unless you use a bot because the tab key event is caught by the browser.
You can use paste (CTRL+V) to paste text with <tab>s into an input box.
Post 02 Feb 2014, 14:26
View user's profile Send private message Visit poster's website Reply with quote
Display posts from previous:
Post new topic Reply to topic

Jump to:  


< Last Thread | Next Thread >

Forum Rules:
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Copyright © 2004-2018, Tomasz Grysztar.

Powered by rwasa.